Hello coders, today we are going to solve Sum and Prod HackerRank Solution in Python.
Obective
The sum tool returns the sum of array elements over a given axis.
import numpy
my_array = numpy.array([ [1, 2], [3, 4] ])
print numpy.sum(my_array, axis = 0) #Output : [4 6]
print numpy.sum(my_array, axis = 1) #Output : [3 7]
print numpy.sum(my_array, axis = None) #Output : 10
print numpy.sum(my_array) #Output : 10
By default, the axis value is None
. Therefore, it performs a sum over all the dimensions of the input array.
The prod tool returns the product of array elements over a given axis.
import numpy
my_array = numpy.array([ [1, 2], [3, 4] ])
print numpy.prod(my_array, axis = 0) #Output : [3 8]
print numpy.prod(my_array, axis = 1) #Output : [ 2 12]
print numpy.prod(my_array, axis = None) #Output : 24
print numpy.prod(my_array) #Output : 24
By default, the axis value is None
. Therefore, it performs the product over all the dimensions of the input array.
Task
You are given a 2-D array with dimensions N X M.
Your task is to perform the sum tool over axis 0 and then find the product of that result.
Input Format
The first line of input contains space separated values of N and M.
The next N lines contains M space separated integers.
Output Format
Compute the sum along axis 0. Then, print the product of that sum.
Sample Input
2 2
1 2
3 4
Sample Output
24
Explanation
The sum along axis 0 = [ 4 6 ]
The product of this sum = 24
Solution – Sum and Prod in Python
import numpy N, M = map(int, input().split()) A = numpy.array([input().split() for _ in range(N)],int) print(numpy.prod(numpy.sum(A, axis=0), axis=0))
Disclaimer: The above Problem (Sum and Prod) is generated by Hacker Rank but the solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.