Java Static Initializer Block | HackerRank Solution

Hello coders, today we are going to solve Java Static Initializer Block HackerRank Solution.

Java Static Initializer Block

Problem

Static initialization blocks are executed when the class is loaded, and you can initialize static variables in those blocks.

It’s time to test your knowledge of Static initialization blocks. You can read about it here.

You are given a class Solution with a main method. Complete the given code so that it outputs the area of a parallelogram with breadth B
and height H. You should read the variables from the standard input.

If B <= 0 or H <= 0, the output should be “java.lang.Exception: Breadth and height must be positive” without quotes.

Input Format

There are two lines of input. The first line contains B : the breadth of the parallelogram. The next line contains H : the height of the parallelogram.

Constraints

  • -100 <= B <= 100
  • -100 <= H <= 100

Output Format

If both values are greater than zero, then the main method must output the area of the parallelogram. Otherwise, print “java.lang.Exception: Breadth and height must be positive” without quotes.

Sample Input 1

 1
 3

Sample Output 1

 3

Sample Input 2

 -1
 2

Sample Output 2

 java.lang.Exception: Breadth and height must be positive

Solution – Java Static Initializer Block

import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {
public static int B,H;
private static boolean flag = false;

static
{
    Scanner sc = new Scanner(System.in);
     B = sc.nextInt();
     H = sc.nextInt();
    if(B>0 && H>0)
    {
        flag = true;
    }
    else
    {
        System.out.println("java.lang.Exception: Breadth and height must be positive");
    }
}

public static void main(String[] args){
		if(flag){
			int area=B*H;
			System.out.print(area);
		}
		
	}//end of main

}//end of class

Disclaimer: The above Problem ( Java Static Initializer Block ) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

Leave a Comment

Your email address will not be published. Required fields are marked *