For Loop in C | HackerRank Solution

Hello coderz, today we will be solving For Loop in C HackerRank Solution.

For Loop in C

Objective

In this challenge, you will learn the usage of the for loop, which is a programming language statement which allows code to be executed until a terminal condition is met. They can even repeat forever if the terminal condition is never met.

The syntax for the for loop is:

for ( <expression_1> ; <expression_2> ; <expression_3> )
    <statement>

expression_1 is used for initializing variables which are generally used for controlling the terminating flag for the loop.

expression_2 is used to check for the terminating condition. If this evaluates to false, then the loop is terminated.

expression_3 is generally used to update the flags/variables.

The following loop initializes i to 0, tests that i is less than 10, and increments i at every iteration. It will execute 10 times.

for(int i = 0; i < 10; i++) {
    ...
}

Task

For each integer n in the interval [a,b] (given as input) :

  • If 1<=n<=9, then print the English representation of it in lowercase. That is “one” for 1, “two” for 2, and so on.
  • Else if n>9 and it is an even number, then print “even”.
  • Else if n>9 and it is an odd number, then print “odd”.

Input Format

The first line contains an integer, a.

The second line contains an integer, b.

Constraints

1<=a<=b<=10^6

Output Format

Print the appropriate English representation,even, or odd, based on the conditions described in the ‘task’ section.
Note: [a,b] = {x ∈ Z | axb}

Sample Input

8
11

Sample Output

eight
nine
even
odd

Solution – For Loop in C HackerRank Solution

#include &lt;stdio.h&gt;
#include &lt;string.h&gt;
#include &lt;math.h&gt;
#include &lt;stdlib.h&gt;

int main() 
{
    int a, b;
    scanf("%d\n%d", &amp;a, &amp;b);
  	// Complete the code.
      char num_name[11][6]={"one","two","three","four","five","six","seven","eight","nine","even","odd"};
    for(int i=a; i&lt;=b ;i++)
    {
        int num_i = i&lt;=9 ? i-1 : 9 + i % 2;
        printf("%s \n",num_name[num_i]);
    }

    return 0;
}
For Loop in C HackerRank Solution
For Loop in C HackerRank Solution

Disclaimer: The above Problem (For Loop in C) is generated by Hacker Rank but the Solution is provided by CodingBroz.

Broz Who Code

CodingBroz

1 thought on “For Loop in C | HackerRank Solution”

  1. int main()
    {
    int a, b,n;
    scanf(“%d\n%d”, &a, &b);
    // Complete the code.
    for(n=a;n=1 && n9 && n%2==0)
    {
    printf(“even\n”);
    }
    if(n>9 && n%2==1){
    printf(“odd\n”);
    }
    }
    return 0;
    }

Leave a Comment

Your email address will not be published. Required fields are marked *