Vector Sort in C++ | HackerRank Solution

In this post, we will be solving Vector Sort HackerRank Solution in C++.

vector-sort-in-c++-hackerrank-solution-codingbroz

Task

You are given N integers.Sort the N integers and print the sorted order.

Store the N integers in a vector.Vectors are sequence containers representing arrays that can change in size.

  Declaration:

 vector<int>v; (creates an empty vector of integers)

Size:


    int size=v.size();

    Pushing an integer into a vector:

    v.push_back(x);(where x is an integer.The size increases by 1 after this.)

    Popping the last element from the vector:

    v.pop_back(); (After this the size decreases by 1)

Sorting a vector:

 sort(v.begin(),v.end()); (Will sort all the elements in the vector)

Input Format

The first line of the input contains N where N is the number of integers. The next line contains N integers.

Constraints

1 <= n <= 105

1 <= Vi <= 109 , where Vi is the ith integer in the vector.

Output Format

Print the integers in the sorted order one by one in a single line followed by a space.

Sample Input

5
1 6 10 8 4

Sample Output

1 4 6 8 10

Solution – Vector Sort HackerRank Solution in C++

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;


int main() {
    /* Enter your code here. Read input from STDIN. Print output to STDOUT */   
    int n; cin >> n;
    vector<int> arr;
    int x;
    for(int i=0 ; i<n ;i++)
    {
        cin >> x;
        arr.push_back(x);
    }
   sort(arr.begin(),arr.end());
    for(int i=0 ; i<arr.size();i++)
    {
        cout<< arr[i] <<' ';
    }
    return 0;
}
Vector Sort HackerRank Solution in C++
Vector Sort HackerRank Solution in C++

Disclaimer: The above Problem (Vector Sort in C++) is generated by Hacker Rank but the Solution is provided by CodingBroz.

Broz Who Code

CodingBroz

Leave a Comment

Your email address will not be published. Required fields are marked *