Triangle Quest 2 in Python | HackerRank Solution

Hello coders, today we are going to solve Triangle Quest 2 HackerRank Solution in Python.

Triangle Quest 2 in Python

Task

You are given a positive integer N.
Your task is to print a palindromic triangle of size N.

For example, a palindromic triangle of size 5 is:

1
121
12321
1234321
123454321

You can’t take more than two lines. The first line (a for-statement) is already written for you.
You have to complete the code using exactly one print statement.

Note:
Using anything related to strings will give a score of 0.
Using more than one for-statement will give a score of 0.

Input Format

A single line of input containing the integer N.

Constraints

  • 0 < N < 10

Output Format

Print the palindromic triangle of size N as explained above.

Sample Input

5

Sample Output

1
121
12321
1234321
123454321

Solution – Triangle Quest 2 in Python

for i in range(1, int(input())+1):
    print(((10**i)//9)**2)

Disclaimer: The above Problem (Triangle Quest 2) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

Leave a Comment

Your email address will not be published. Required fields are marked *