String Split and Join | HackerRank Solution

Hello coders, today we are going to solve String Split and Join Hacker Rank Solution in Python.

String Split and Join - Hacker Rank Solution

Objective

In Python, a string can be split on a delimiter.

Example

>>> a = "this is a string"
>>> a = a.split(" ") # a is converted to a list of strings. 
>>> print a
['this', 'is', 'a', 'string']

Joining a string is simple:

>>> a = "-".join(a)
>>> print a
this-is-a-string 

Task

You are given a string. Split the string on a ” ” (space) delimiter and join using a – hyphen.

Input Format

The first line contains a string consisting of space separated words.

Output Format

Print the formatted string as explained above.

Sample Input

this is a string

Sample Output

this-is-a-string

Solution – String Split and Join – Hacker Rank Solution

def split_and_join(line):
    # write your code here
    line = line.split()
    line = "-".join(line)
    return line

if __name__ == '__main__':
    line = input()
    result = split_and_join(line)
    print(result)

Disclaimer: The above Problem (String Split and Join) is generated by Hacker Rank but the Solution is provided by CodingBroz. This tutorial is only for Educational and Learning purposes.

Leave a Comment

Your email address will not be published. Required fields are marked *