Reduce Function in Python | HackerRank Solution

Hello coders, today we are going to solve Reduce Function HackerRank Solution in Python.

Reduce Function in Python

Task

Given a list of rational numbers,find their product.

Concept
The reduce() function applies a function of two arguments cumulatively on a list of objects in succession from left to right to reduce it to one value. Say you have a list, say [1,2,3] and you have to find its sum.

>>> reduce(lambda x, y : x + y,[1,2,3])
6

You can also define an initial value. If it is specified, the function will assume initial value as the value given, and then reduce. It is equivalent to adding the initial value at the beginning of the list. For example:

>>> reduce(lambda x, y : x + y, [1,2,3], -3)
3

>>> from fractions import gcd
>>> reduce(gcd, [2,4,8], 3)
1

Input Format

First line contains n, the number of rational numbers.
The ith of next n lines contain two integers each, the numerator( Ni ) and denominator( Di ) of the ith rational number in the list.

Constraints

  • 1 <= n <= 100
  • 1 <= Ni, Di <= 109

Output Format

Print only one line containing the numerator and denominator of the product of the numbers in the list in its simplest form, i.e. numerator and denominator have no common divisor other than 1.

Sample Input 0

3
1 2
3 4
10 6

Sample Output 0

5 8

Explanation 0

Required product is 5 / 8

Solution – Reduce Function in Python

from fractions import Fraction
from functools import reduce

def product(fracs):
    t = Fraction(reduce(lambda x, y: x * y, fracs))
    return t.numerator, t.denominator

if __name__ == '__main__':
    fracs = []
    for _ in range(int(input())):
        fracs.append(Fraction(*map(int, input().split())))
    result = product(fracs)
    print(*result)

Disclaimer: The above Problem (Reduce Function) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

Leave a Comment

Your email address will not be published. Required fields are marked *