Python: Division | HackerRank Solution

Hello coders, today we will be solving Python: Division Hacker Rank Solution.

Python: Division - Hacker Rank Solution

Task

The provided code stub read two integers, a and b, from STDIN.

Add logic to print two lines. The first line should contain the result of integer division, a // b. The second line should contain the result of float division, a / b.

No rounding or formatting is necessary.

Example

a = 3

b = 5

  • The result of the integer division 3 // 5 = 0.
  • The result of the float division 3 / 5 = 0.6. 

Print:

0
0.6

Input Format

The first line contains the first integer, a.

The second line contains the second integer, b.

Output Format

Print the two lines as described above.

Sample Input 0

4
3

Sample Output 0

1
1.33333333333

Solution – Python: Division – Hacker Rank Solution

if __name__ == '__main__':
    a = int(input())
    b = int(input())
    print(a // b)
    print(a / b)

Disclaimer: The above Problem (Python: Division) is generated by Hacker Rank but the Solution is provided by CodingBroz. This tutorial is only for Educational and Learning Purposes.

4 thoughts on “Python: Division | HackerRank Solution”

  1. if __name__ == ‘__main__’:
    a = int(input())
    b = int(input())
    result_1=int(a//b)
    result_2=float(a/b)
    print(result_1)
    print(result_2)

Leave a Comment

Your email address will not be published. Required fields are marked *