Nested Lists in Python | HackerRank Solution

Hey coders, today we are going to solve Nested Lists in Python Hacker Rank Solution.

Nested Lists in Python - Hacker Rank Solution

Problem

Given the names and grades for each student in a class of N students, store them in a nested list and print the name(s) of any student(s) having the second lowest grade.

Note: If there are multiple students with the second lowest grade, order their names alphabetically and print each name on a new line.

Example

records  = [[ “chi”, 20.0]], [“beta”, 50.0], [“alpha”, 50.0]

The ordered list of scores is [20.0, 50.0], so the second lowest score is 50.0. There are two students with that score: [“beta”, “alpha”]. Ordered alphabetically, the names are printed as:

alpha
beta

Input Format

The first line contains an integer, , the number of students.
The  subsequent lines describe each student over  lines.

  • The first line contains a student’s name.
  • The second line contains their grade.

Constraints

  • 2 <= N <= 5
  • There will always be one or more students having the second lowest grade.

Output Format

Print the name(s) of any student(s) having the second lowest grade in. If there are multiple students, order their names alphabetically and print each one on a new line.

Sample Input 0

5
Harry
37.21
Berry
37.21
Tina
37.2
Akriti
41
Harsh
39

Sample Output 0

Berry
Harry

Explanation 0

There are 5 students in this class whose names and grades are assembled to build the following list:

python students = [[‘Harry’, 37.21], [‘Berry’, 37.21], [‘Tina’, 37.2], [‘Akriti’, 41], [‘Harsh’, 39]]

The lowest grade of 37.2 belongs to Tina. The second lowest grade of 37.21 belongs to both Harry and Berry, so we order their names alphabetically and print each name on a new line.

Solution – Nested Lists in Python – Hacker Rank Solution

Result =[]
scorelist = []

if __name__ == '__main__':
    for _ in range(int(input())):
        name = input()
        score = float(input())
        Result+=[[name,score]]
        scorelist+=[score]
    b=sorted(list(set(scorelist)))[1] 

    for a,c in sorted(Result):
        if c==b:
            print(a)

Disclaimer: The above Problem (Nested List) is generated by Hacker Rank but the Solution is provided by CodingBroz. This tutorial is only for Educational and Learning purposes.

15 thoughts on “Nested Lists in Python | HackerRank Solution”

  1. This is how beginner’s solution look like as compare your solution.
    if __name__ == ‘__main__’:
    li = []
    for _ in range(int(input())):
    name = input()
    score = float(input())
    li.append([name,score])

    py = sorted(li, key = lambda x: x[1])
    first_elem_last_index = 0

    for j in range(1,len(py)):
    if py[0][1] == py[j][1]:
    first_elem_last_index = j

    second_elem = first_elem_last_index + 1

    common_elem = []
    printed = True

    for next_elem in range(second_elem,len(py)-1):
    next_elem += 1

    if printed:
    common_elem.append(py[second_elem])
    printed = False

    if py[second_elem][1] == py[next_elem][1]:
    common_elem.append(py[next_elem])

    srt_name = sorted(common_elem)
    # print(srt_name)

    for index,value in enumerate(srt_name):
    print(value[0])

    1. To run current file
      when you open pycharm default name is main.py
      it mostly used when you are working with modules
      It runs the current file instead of executing another file

    1. This is a common Python construct used to check if the current script is being run as the main program (not imported as a module in another script). The code block inside this if statement will be executed only when the script is run directly.

    2. To run current file
      when you open pycharm default name is main.py
      it mostly used when you are working with modules
      It runs the current file instead of executing another file

Leave a Comment

Your email address will not be published. Required fields are marked *