Lists in Python | HackerRank Solution

Hello coders, today we are going to solve Lists in Python Hacker Rank Solution.

Lists in Python - Hacker Rank Solution

Problem

Consider a list (list = []). You can perform the following commands:

  1. insert i e: Insert integer e at position i.
  2. print: Print the list.
  3. remove e: Delete the first occurrence of integer e.
  4. append e: Insert integer e at the end of the list.
  5. sort: Sort the list.
  6. pop: Pop the last element from the list.
  7. reverse: Reverse the list.

Initialize your list and read in the value of n followed by n lines of commands where each command will be of the 7 types listed above. Iterate through each command in order and perform the corresponding operation on your list.

Example

N = 4
append 1
append 2
insert 3 1
print

  • append 1: Append 1 to the list, arr = [1].
  • append 2: Append 2 to the list, arr [1, 2].
  • insert 3 1: Insert at index 1,arr = [1, 3, 2].
  • print: Print the array.

Output:

[1, 3, 2]

Input Format

The first line contains an integer, n, denoting the number of commands.
Each line i of the n subsequent lines contains one of the commands described above.

Constraints

The elements added to the list must be integers.

Output Format

For each command of type print, print the list on a new line.

Sample Input 0

12
insert 0 5
insert 1 10
insert 0 6
print
remove 6
append 9
append 1
sort
print
pop
reverse
print

Sample Output 0

[6, 5, 10]
[1, 5, 9, 10]
[9, 5, 1]

Solution – Lists in Python – Hacker Rank Solution

if __name__ == '__main__':
    N = int(input())
    L=[];
    for i in range(0,N):
        cmd=input().split();
        if cmd[0] == "insert":
            L.insert(int(cmd[1]),int(cmd[2]))
        elif cmd[0] == "append":
            L.append(int(cmd[1]))
        elif cmd[0] == "pop":
            L.pop();
        elif cmd[0] == "print":
            print(L)
        elif cmd[0] == "remove":
            L.remove(int(cmd[1]))
        elif cmd[0] == "sort":
            L.sort();
        else:
            L.reverse();

Disclaimer: The above Problem (Lists in Python) is generated by Hacker Rank but the Solution is provided by CodingBroz. This tutorial is only for Educational and Learning purposes.

4 thoughts on “Lists in Python | HackerRank Solution”

  1. SRUJANA SRAVANTHI

    Hey, its showing an error bro!
    In that list answer, I copied your code as i am unable to understand the strategy.
    I hope you will correct the error, Thank you!

  2. if __name__ == ‘__main__’:
    students_grade =[]
    for i in range(int(input())):
    name=input()
    score=float(input())
    students_grade.append([name,score])
    sorted_scored=sorted(list(set([*[1]for*in students_grade])))
    #fetching 2nd_lowest_score from unique_sorted_scores
    second_lowest=sorted_scores[1]

    low_final_list=[]
    for student in students_grade:
    #checking 2nd_lowest_score to each student[score]
    if second_lowest==student[1]:
    low_final_list append(student[0])

    for student in sorted(low_final_list):
    print(student)

  3. if __name__ == ‘__main__’:
    N = int(input())
    L = []
    for i in range(N):
    call = input().split()
    if call[0] == ‘insert’:
    L.insert(int(call[1]), int(call[2]))
    elif call[0] == “print”:
    print(L)
    elif call[0] == “remove” and len(call) == 2:
    L.remove(int(call[1]))
    elif call[0] == ‘append’ and len(call) == 2:
    L.append(int(call[1]))
    elif call[0] == ‘sort’:
    L.sort()
    elif call[0] == ‘pop’ and len(call) == 1:
    L.pop()
    elif call[0] == ‘reverse’:
    L.reverse()
    else:
    print(“Invalid command”)

Leave a Comment

Your email address will not be published. Required fields are marked *