Hello coders, today we are going to solve Linear Algebra HackerRank Solution in Python.
Objective
The NumPy module also comes with a number of built-in routines for linear algebra calculations. These can be found in the sub-module linalg.
The linalg.det tool computes the determinant of an array.
print numpy.linalg.det([[1 , 2], [2, 1]]) #Output : -3.0
The linalg.eig computes the eigenvalues and right eigenvectors of a square array.
vals, vecs = numpy.linalg.eig([[1 , 2], [2, 1]])
print vals #Output : [ 3. -1.]
print vecs #Output : [[ 0.70710678 -0.70710678]
# [ 0.70710678 0.70710678]]
The linalg.inv tool computes the (multiplicative) inverse of a matrix.
print numpy.linalg.inv([[1 , 2], [2, 1]]) #Output : [[-0.33333333 0.66666667]
# [ 0.66666667 -0.33333333]]
Task
You are given a square matrix A with dimensions N X N. Your task is to find the determinant. Note: Round the answer to 2 places after the decimal.
Input Format
The first line contains the integer N.
The next N lines contains the N space separated elements of array A.
Output Format
Print the determinant of A.
Sample Input
2
1.1 1.1
1.1 1.1
Sample Output
0.0
Solution – Linear Algebra in Python
import numpy as np np.set_printoptions(legacy='1.13') n = int(input()) array = np.array([input().split() for _ in range(n)], float) print(np.linalg.det(array))
Disclaimer: The above Problem (Linear Algebra) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.