Java Substring | HackerRank Solution

Hello coders, today we are going to solve Java Substring HackerRank Solution.

Java Substring

Problem

Given a string, s, and two indices, start and end, print a substring consisting of all characters in the inclusive range from start to end – 1. You’ll find the String class’ substring method helpful in completing this challenge.

Input Format

The first line contains a single string denoting s.
The second line contains two space-separated integers denoting the respective values of start and end.

Constraints

  • 1 <= |s| <= 100
  • 0 <= start < end <= n
  • String s consists of English alphabetic letters (i.e.: [ az, AZ ]only)

Output Format

Print the substring in the inclusive range from start to end-1.

Sample Input
 Helloworld
 3 7
Sample Output
 lowo
Explanation

In the diagram below, the substring is highlighted in green:

Source- HackerRank

Solution – Java Substring

import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String S = in.next();
        int start = in.nextInt();
        int end = in.nextInt();
        System.out.print(S.substring(start,end));
    }
}

Disclaimer: The above Problem (Java Substring) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

Leave a Comment

Your email address will not be published. Required fields are marked *