Java Stack | HackerRank Solution

Hello coders, today we are going to solve Java Stack HackerRank Solution.

Java Stack

Problem

In computer science, a stack or LIFO (last in, first out) is an abstract data type that serves as a collection   of elements, with two principal operations: push, which adds an element to the collection, and pop, which removes the last element that was added.(Wikipedia)

A string containing only parentheses is balanced if the following is true: 1. if it is an empty string 2. if A and B are correct, AB is correct, 3. if A is correct, (A) and {A} and [A] are also correct.
Examples of some correctly balanced strings are: “{}()”, “[{()}]”, “({()})”
Examples of some unbalanced strings are: “{}(“, “({)}”, “[[“, “}{” etc.
Given a string, determine if it is balanced or not.

Input Format

There will be multiple lines in the input file, each having a single non-empty string. You should read input till end-of-file.
The part of the code that handles input operation is already provided in the editor.

Output Format

For each case, print ‘true’ if the string is balanced, ‘false’ otherwise.

Sample Input

 {}()
 ({()})
 {}(
 []

Sample Output

 true
 true
 false
 true

Solution – Java Stack

import java.util.*;
import java.io.*;
import java.util.*;

public class Solution {
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()) {
			String input = sc.next();
			System.out.println(balanaced(input));
		}
	}
	
	public static boolean balanaced(String s) {
		Stack<Character> stack = new Stack<Character>();
		for(int i = 0; i < s.length(); i++) {
			char c = s.charAt(i);
			if(c =='[' || c == '(' || c == '{') {
				stack.push(c);
			}else if(c == ']') {
				if(stack.isEmpty() || stack.pop() != '[') {
					return false;
				}
			}else if(c == ')') {
				if(stack.isEmpty() || stack.pop() != '(') {
					return false;
				}
			}else if(c == '}') {
				if(stack.isEmpty() || stack.pop() != '{') {
					return false;
				}
			}
		}
		return stack.isEmpty();
	}
}

Disclaimer: The above Problem ( Java Stack ) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

Leave a Comment

Your email address will not be published. Required fields are marked *