Hello coders, today we are going to solve Inner and Outer HackerRank Solution in Python.
Objective
The inner tool returns the inner product of two arrays.
import numpy
A = numpy.array([0, 1])
B = numpy.array([3, 4])
print numpy.inner(A, B) #Output : 4
The outer tool returns the outer product of two arrays.
import numpy
A = numpy.array([0, 1])
B = numpy.array([3, 4])
print numpy.outer(A, B) #Output : [[0 0]
# [3 4]]
Task
You are given two arrays: A and B.
Your task is to compute their inner and outer product.
Input Format
The first line contains the space separated elements of array A.
The second line contains the space separated elements of array B.
Output Format
First, print the inner product.
Second, print the outer product.
Sample Input
0 1
2 3
Sample Output
3
[[0 0]
[2 3]]
Solution – Inner and Outer in Python
import numpy as np A = np.array(input().split(), int) B = np.array(input().split(), int) print(np.inner(A,B), np.outer(A,B), sep='\n')
Disclaimer: The above Problem (Inner and Outer) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.