Hello coders, today we are going to solve Dot and Cross HackerRank Solution in Python.
Objective
The dot tool returns the dot product of two arrays
import numpy
A = numpy.array([ 1, 2 ])
B = numpy.array([ 3, 4 ])
print numpy.dot(A, B) #Output : 11
The cross tool returns the cross product of two arrays.
import numpy
A = numpy.array([ 1, 2 ])
B = numpy.array([ 3, 4 ])
print numpy.cross(A, B) #Output : -2
Task
You are given two arrays A and B. Both have dimensions of N X N.
Your task is to compute their matrix product.
Input Format
The first line contains the integer N.
The next N lines contains N space separated integers of array A.
The following N lines contains N space separated integers of array B.
Output Format
Print the matrix multiplication of A and B.
Sample Input
2
1 2
3 4
1 2
3 4
Sample Output
[[ 7 10]
[15 22]]
Solution – Dot and Cross in Python
import numpy as np n = int(input()) a = np.array([input().split() for _ in range(n)], int) b = np.array([input().split() for _ in range(n)], int) print(np.dot(a, b))
Disclaimer: The above Problem (Dot and Cross) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.