Day 0: Hello, World | 30 Days Of Code | HackerRank Solution

Hello coders, today we are going to solve Day 0: Hello, World HackerRank Solution which is a part of 30 Days of Code Series in C++, Java and Python.

Day 0: Hello, World

Objective

In this challenge, we review some basic concepts that will get you started with this series. You will need to use the same (or similar) syntax to read input and write output in challenges throughout HackerRank. Check out the Tutorial tab for learning materials and an instructional video!

Task

To complete this challenge, you must save a line of input from stdin to a variable, print Hello, World. on a single line, and finally print the value of your variable on a second line.

You’ve got this!

Note: The instructions are Java-based, but we support submissions in many popular languages. You can switch languages using the drop-down menu above your editor, and the inputString variable may be written differently depending on the best-practice conventions of your submission language.

Input Format

A single line of text denoting inputString (the variable whose contents must be printed).

Output Format

Print Hello, World. on the first line, and the contents of inputString on the second line.

Sample Input

Welcome to 30 Days of Code!

Sample Output

Hello, World. 
Welcome to 30 Days of Code!

Explanation

On the first line, we print the string literal Hello, World.. On the second line, we print the contents of the inputString variable which, for this sample case, happens to be Welcome to 30 Days of Code!If you do not print the variable’s contents to stdout, you will not pass the hidden test case.

Solution – Day 0: Hello, World Solution

C

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>

int main() 
{
    /* Declare a variable named 'input_string' to hold our input.*/
    char input_string[105]; 
    
    /* Read a full line of input from stdin and save it to our variable, input_string.*/
    scanf("%[^\n]", input_string); 
    
    /* Print a string literal saying "Hello, World." to stdout using printf.*/
    printf("Hello, World.\n");
    
    /* TO DO: Write a line of code here that prints the contents of input_string to stdout.*/
    
    /* Solution starts from here */
    
    printf("%s",input_string);
    
    /* Solution ends here */
    return 0;
}

C++

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
int main() {
    // Declare a variable named 'input_string' to hold our input.
    string input_string; 

    // Read a full line of input from stdin (cin) and save it to our variable, input_string.
    getline(cin, input_string); 

    // Print a string literal saying "Hello, World." to stdout using cout.
    cout << "Hello, World." << endl;

    // TODO: Write a line of code here that prints the contents of input_string to stdout.
    cout << input_string;

    return 0;
}

Java

import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;
import java.util.Scanner;

public class HelloWorld {
    public static void main(String[] args) 
    {
        /* Create a Scanner object to read input from stdin.*/
        Scanner scan = new Scanner(System.in);

        /* Read a full line of input from stdin and save it to our variable, inputString.*/
        String inputString = scan.nextLine();

        /* Close the scanner object because we've finished reading all of the input from stdin needed for this challenge.*/
        scan.close();

        /* Print a string literal saying "Hello, World." to stdout.*/
        System.out.println("Hello, World.");

        /* Print the contents of inputString to stdout.*/
        
        /* Solution starts from here */
        System.out.println(inputString);
        /* Solution ends here */
    }
}

Python

# Read a full line of input from stdin and save it to our dynamically typed variable, input_string.
input_string = input()

# Print a string literal saying "Hello, World." to stdout.
print('Hello, World.')
# TODO: Write a line of code here that prints the contents of input_string to stdout.
print(input_string)

JavaScript

function processData(inputString) {
    // This line of code prints the first line of output
    console.log("Hello, World.");
    // Write the second line of output that prints the contents of 'inputString' here.
    console.log(inputString);
}

process.stdin.resume();
process.stdin.setEncoding("ascii");
_input = "";
process.stdin.on("data", function (input) {
    _input += input;
});

process.stdin.on("end", function () {
   processData(_input);
});

Disclaimer: The above Problem (Day 0: Hello, World) is generated by Hacker Rank but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

1 thought on “Day 0: Hello, World | 30 Days Of Code | HackerRank Solution”

Leave a Comment

Your email address will not be published. Required fields are marked *