Three Way Communications | CodeChef Solution

Hello coders, today we are going to solve Three Way Communications CodeChef Solution whose Problem Code is COMM3.

Three Way Communications

Task

The Chef likes to stay in touch with his staff. So, the Chef, the head server, and the sous-chef all carry two-way transceivers so they can stay in constant contact. Of course, these transceivers have a limited range so if two are too far apart, they cannot communicate directly.

The Chef invested in top-of-the-line transceivers which have a few advanced features. One is that even if two people cannot talk directly because they are out of range, if there is another transceiver that is close enough to both, then the two transceivers can still communicate with each other using the third transceiver as an intermediate device.

There has been a minor emergency in the Chef’s restaurant and he needs to communicate with both the head server and the sous-chef right away. Help the Chef determine if it is possible for all three people to communicate with each other, even if two must communicate through the third because they are too far apart.

Input Format

The first line contains a single positive integer T ≤ 100 indicating the number of test cases to follow. The first line of each test case contains a positive integer R ≤ 1,000 indicating that two transceivers can communicate directly without an intermediate transceiver if they are at most R meters away from each other. The remaining three lines of the test case describe the current locations of the Chef, the head server, and the sous-chef, respectively. Each such line contains two integers X,Y (at most 10,000 in absolute value) indicating that the respective person is located at position X,Y.

Output Format

For each test case you are to output a single line containing a single string. If it is possible for all three to communicate then you should output “yes”. Otherwise, you should output “no”.

To be clear, we say that two transceivers are close enough to communicate directly if the length of the straight line connecting their X,Y coordinates is at most R.

Example

Sample Input

3
1
0 1
0 0
1 0
2
0 1
0 0
1 0
2
0 0
0 2
2 1

Sample Output

yes
yes
no

Solution – Three Way Communications | CodeChef Solution

C++

#include <bits/stdc++.h>
using namespace std;

float calc_dist(int p1[], int p2[])
{
    float dist;
    dist=sqrt(pow(p1[0]-p2[0],2)+pow(p1[1]-p2[1],2));
    //cout<<dist<<"\n";
    return dist;
}

int main() {
	// your code goes here
	int t,p1[2],p2[2],p3[2],i,r,val;
	float dis[3];
	cin>>t;
	while(t--)
	{   val=0;
	    cin>>r;
	    for(i=0;i<2;i++)
	    {
	        cin>>p1[i];
	    }
	    for(i=0;i<2;i++)
	    {
	        cin>>p2[i];
	    }
	    for(i=0;i<2;i++)
	    {
	        cin>>p3[i];
	    }
	    dis[0]=calc_dist(p1,p2);
	    dis[1]=calc_dist(p2,p3);
	    dis[2]=calc_dist(p1,p3);
	    for(i=0;i<3;i++)
	    {
	        if(dis[i]<=r)
	        {
	            val++;   
	        }
	    }
	    if(val>=2){cout<<"yes";}
	    else{cout<<"no";}
	    cout<<"\n";
	}
	return 0;
}

Python

# cook your dish here
for  i in range(int(input())) :
    r=int(input())
    x1,y1=map(int,input().split())
    x2,y2=map(int,input().split())
    x3,y3=map(int,input().split())
    d1=((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)) 
    d2=((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3)) 
    d3=((x3-x2)*(x3-x2)+(y3-y2)*(y3-y2))
    if (d1<=r*r and d2<=r*r) or (d1<=r*r and d3<=r*r) or (d2<=r*r and d3<=r*r) :
        print("yes")
    else :
        print("no")

Java

/* package codechef; // don't place package name! */

import java.util.*;
import java.lang.*;
import java.io.*;

/* Name of the class has to be "Main" only if the class is public. */

public class Main
{
	public static void main (String[] args) throws java.lang.Exception
	{
	Scanner s = new Scanner(System.in);
		int test = s.nextInt();
		for(int i =0;i<test;i++){
		     int r =s.nextInt();
		     int x1=s.nextInt(); int y1=s.nextInt();
		     int x2=s.nextInt(); int y2=s.nextInt();
		     int x3=s.nextInt(); int y3=s.nextInt();
		     double d1=Math.sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
		     double d2=Math.sqrt((x3-x2)*(x3-x2)+(y3-y2)*(y3-y2));
		     double d3=Math.sqrt((x3-x1)*(x3-x1)+(y3-y1)*(y3-y1));
		      if (d1<=r&&d2<=r){
                System.out.println("yes");
            }
            else if (d3<=r&&d2<=r){
                System.out.println("yes");
            }
            else if (d3<=r&&d1<=r){
                System.out.println("yes");
            }
            else {
                System.out.println("no");
            }
		     
		}
}
}

Disclaimer: The above Problem (Three Way Communications) is generated by CodeChef but the Solution is Provided by CodingBroz. This tutorial is only for Educational and Learning Purpose.

Leave a Comment

Your email address will not be published. Required fields are marked *